我们写辅助,特别喜欢把辅助中的操作环节,流程步骤顺序,以及游戏的信息显示在辅助的窗口,我们通常采用易语言超级列表框或者编辑框作为窗口显示首先组件,对于这些组件,我们可以看作是一个对象,程序在创建这些组件时,会耗费大量的系统资源,特别是多线程中每个线程都操作共同的窗口组件,会造成线程的堵塞,甚至崩溃,大漠foobar做为一个透明播放器,可以方便的创建在游戏窗口上, 并且我们能把所有的窗口运行情况记录写到本地,便于我们查看辅助运行日志。你可以先预览效果:

大漠foobar在多线程游戏中滚动显示与本地存储辅助信息

大漠foobar在多线程游戏中滚动显示与本地存储辅助信息

一、创建foobar

1、CreateFoobarRect(创建矩形窗口)
2、CreateFoobarRoundRect(创建圆角矩形窗口)
3、CreateFoobarEllipse(创建椭圆窗口)
4、CreateFoobarCustom(创建自定义形状窗口)

二、关闭/透明度/刷新

5、FoobarClose
6、FoobarSetTrans(设置指定Foobar窗口的是否透明)
7、FoobarUpdate(刷新指定的Foobar窗口)

三、锁定和解锁

8、FoobarLock(锁定)
9、FoobarUnlock(解锁)

四、绘制/填充

10、FoobarDrawLine(窗口内部画线条)
11、FoobarDrawPic(窗口绘制图像)
12、FoobarFillRec在指定的Foobar窗口内部填充矩形
13、FoobarStartGif(在指定的Foobar窗口绘制gif动画.)
14、FoobarStopGif(停止在指定foobar里显示的gif动画.)

五、文字相关

15、FoobarDrawText(指定的Foobar窗口绘制文字)
16、FoobarClearText(清除指定的Foobar滚动文本区)
17、FoobarPrintText(向指定的Foobar窗口区域内输出滚动文字)
18、FoobarSetFont(设置指定Foobar窗口的字体)
19、FoobarSetSave(设置保存指定的Foobar滚动文本区信息到文件.)
20、FoobarTextLineGap(设置滚动文本区的文字行间距,默认是3)
21、FoobarTextPrintDir(设置滚动文本区的文字输出方向,默认是0)
22、FoobarTextRect(设置指定Foobar窗口的滚动文本框范围,默认的文本框范围是窗口区域)

课程目录

1、了解foobar演示foobar在游戏中的应用
2、大漠类模块的快速生成及免注册调用后台绑定游戏
3、创建foobar窗口
4、foobar刷新及随机绘制线条实例演示- FoobarDrawLine
5、foobar绘制图像GIF及填充矩形
6、FoobarDrawText游戏窗口绘制文字实现跑马灯效果
7、FoobarPrintText向游戏窗口滚动输出文字
8、FoobarSetSave保存指定的Foobar滚动文本区信息到文件
9、大漠多线程框架模板构建
10、在多线程(多任务单次)中实现辅助流程信息滚动写出A-B-C-D-E-F
11、在多线程(多任多次-死循环)中实现辅助流程信息滚动写出保存信息到本地
12、多种方法实现组合按键和单键实现辅助的隐藏与显示及程序图标置换

部分源码:

foobar组件的创建

注意:这里创建后返回的句柄是一个数组foobar_hwnd [m] ,因为我们要在多线程里每个窗口都显示

.版本 2
 
.子程序 foobar
.参数 m
.局部变量 foobar
 
foobar_hwnd [m] = dm [m].CreateFoobarRect (gamethwnd [m], 0, 319, 302, 158)
foobar = foobar_hwnd [m]
 
dm [m].FoobarLock (foobar)
' 设置字体
' 设置行距
dm [m].FoobarFillRect (foobar, 0, 0, 302, 158, “0000FF”)
dm [m].FoobarUpdate (foobar)

把多个窗口的信息写入本地txt文件

txt文件命名是采用启动事件。

.版本 2
 
.子程序 foobarsave
.参数 m
.局部变量 foobar, 整数型, , , 句柄
.局部变量 path, 文本型, , , 保存路径
 
path = 取运行目录 () + “\log\” + 到文本 (取现行时间 ()) + “.txt”
 
foobar = foobar_hwnd [m]
dm [m].FoobarSetSave (foobar, path, 1, “[%L04d%] (%hh%-%mm%)”)

解压密码:

www.511yj.com
下载地址和提取码:
链接:https://pan.baidu.com/s/1M86Qbk59AG9Y7BdNzq6MgQ
教程演示

知乎:https://www.zhihu.com/zvideo/1285669888074858496
优酷:https://v.youku.com/v_show/id_XNDg0MDc5Mzc1Mg==.html
爱奇艺:https://www.iqiyi.com/v_k558pzgcjw.html
bilibili:https://www.bilibili.com/video/BV1Kv41117cG/
腾讯视频:https://v.qq.com/x/page/m3147ijvq1v.html
好看视频:https://haokan.baidu.com/v?vid=13156720907687740389
西瓜视频:https://www.ixigua.com/6868978164706574855?logTag=Y-MAMeCG3qjepY9QgjtNt

511遇见:http://www.511yj.com/course/index.html
 

您可能感兴趣的文章:


▪ 大漠foobar在游戏中滚动显示视频演示

▪ 大漠多线程循环任务自动切换模板-3一键开启和关闭游戏

▪ 大漠多账号循环登录任务自动切换模板-9测试优化

▪ 易语言多线程foobar输出辅助信息保存到文本文件

▪ 大漠多账号循环登录任务自动切换模板-6大漠绑定游戏

▪ 大漠多账号循环登录任务自动切换模板-2读取账号到超级列表框

▪ 大漠多线程循环任务自动切换模板-6脚本主线程控制

▪ 大漠多线程循环任务自动切换模板-7自动切换账号

▪ 易语言大漠《剑侠情缘》多线程批量登录

▪ 大漠多账号循环登录任务自动切换模板-3免注册调用大漠

原文链接:https://blog.csdn.net/zcp528/article/details/108547789

最后修改日期:2020年9月15日